<!DOCTYPE html><html lang="en-US" prefix="og: http://ogp.me/ns#"><head ><link rel="stylesheet" type="text/css" href="http://www.contentmasteryguide.com/wp-content/cache/minify/b3847.css" media="all" /><meta charset="UTF-8" /><title>How to Manage Your Blogging Tasks -</title><meta name="viewport" content="width=device-width, initial-scale=1" /><style>@font-face{font-family:"sw-icon-font";src:url("http://www.contentmasteryguide.com/wp-content/plugins/social-warfare/fonts/sw-icon-font.eot?ver=2.2.5");src:url("http://www.contentmasteryguide.com/wp-content/plugins/social-warfare/fonts/sw-icon-font.eot?ver=2.2.5#iefix") format("embedded-opentype"),url("http://www.contentmasteryguide.com/wp-content/plugins/social-warfare/fonts/sw-icon-font.woff?ver=2.2.5") format("woff"), url("http://www.contentmasteryguide.com/wp-content/plugins/social-warfare/fonts/sw-icon-font.ttf?ver=2.2.5") format("truetype"),url("http://www.contentmasteryguide.com/wp-content/plugins/social-warfare/fonts/sw-icon-font.svg?ver=2.2.5#1445203416") format("svg");font-weight:normal;font-style:normal}</style><link rel="canonical" href="http://www.contentmasteryguide.com/2017/05/manage-blogging-tasks.html" /><link rel="publisher" href="https://plus.google.com/+LindaDessau"/><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="How to Manage Your Blogging Tasks -" /><meta property="og:description" content="So swamped with to-dos that nothing’s getting done? How to manage your blogging tasks with a tool like Wunderlist." /><meta property="og:url" content="http://www.contentmasteryguide.com/2017/05/manage-blogging-tasks.html" /><meta property="og:site_name" content="Content Mastery Guide" /><meta property="article:publisher" content="https://www.facebook.com/contentmasteryguide" /><meta property="article:section" content="Blogging Basics" /><meta property="article:published_time" content="2017-05-17T13:05:30-04:00" /><meta property="article:modified_time" content="2017-05-17T14:54:51-04:00" /><meta property="og:updated_time" content="2017-05-17T14:54:51-04:00" /><meta property="og:image" content="http://www.contentmasteryguide.com/images/2017/05/blogging-tasks-text.png" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="So swamped with to-dos that nothing’s getting done? How to manage your blogging tasks with a tool like Wunderlist." /><meta name="twitter:title" content="How to Manage Your Blogging Tasks -" /><meta name="twitter:site" content="@lindadessau" /><meta name="twitter:image" content="http://www.contentmasteryguide.com/images/2017/05/blogging-tasks-text.png" /><meta name="twitter:creator" content="@lindadessau" /><meta property="DC.date.issued" content="2017-05-17T13:05:30-04:00" /><link rel='dns-prefetch' href='//platform-api.sharethis.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Content Mastery Guide &raquo; Feed" href="http://www.contentmasteryguide.com/feed" /><link rel="alternate" type="application/rss+xml" title="Content Mastery Guide &raquo; Comments Feed" href="http://www.contentmasteryguide.com/comments/feed" /><link rel="alternate" type="application/rss+xml" title="Content Mastery Guide &raquo; How to Manage Your Blogging Tasks Comments Feed" href="http://www.contentmasteryguide.com/2017/05/manage-blogging-tasks.html/feed" /> <script type="text/javascript">/*<![CDATA[*/window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.contentmasteryguide.com\/wp-includes\/js\/wp-emoji-release.min.js"}};!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);/*]]>*/</script> <style type="text/css">img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0
.07em !important;vertical-align:-0.1em !important;background:none !important;padding:0
!important}</style><style id='aspire-pro-inline-css' type='text/css'>a,
.genesis-nav-menu a:focus,
.genesis-nav-menu a:hover,
.entry-title a:hover,
.image-section a:hover,
.image-section .featured-content .entry-title a:hover,
.site-footer a:hover{color:#d66c59}button,
input[type="button"],
input[type="reset"],
input[type="submit"],
.archive-pagination li a:hover,
.archive-pagination .active a,
.button,
.widget .button,
.front-page-2 .image-section,
.popular,
.genesis-nav-menu .sub-menu a:hover,
.genesis-nav-menu .sub-menu li.current-menu-item > a,
.footer-widgets .enews-widget input[type="submit"]{background-color:#d66c59}button,
input[type="button"],
input[type="reset"],
input[type="submit"],
.button,
.front-page input:focus,
.front-page textarea:focus,
.widget
.button{border-color:#d66c59}</style><link rel='stylesheet' id='google-fonts-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3A300%2C400%2C600%2C700&#038;ver=1.1.3' type='text/css' media='all' /><link rel='stylesheet' id='font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.5.0/css/font-awesome.min.css' type='text/css' media='all' /> <script type="text/javascript" src="http://www.contentmasteryguide.com/wp-content/cache/minify/df983.js"></script> <script type='text/javascript'>var pys_events=[{"type":"init","name":"1281666278538292","params":[]},{"type":"track","name":"PageView","params":{"domain":"www.contentmasteryguide.com"},"delay":0},{"type":"trackCustom","name":"GeneralEvent","params":{"post_type":"post","content_name":"How to Manage Your Blogging Tasks","post_id":6297,"content_category":"Blogging Basics, Blogging Consistently","domain":"www.contentmasteryguide.com"},"delay":0}];</script> <script type="text/javascript" src="http://www.contentmasteryguide.com/wp-content/cache/minify/72e0f.js"></script> <!--[if lt IE 9]> <script type='text/javascript' src='http://www.contentmasteryguide.com/wp-content/themes/genesis/lib/js/html5shiv.js'></script> <![endif]--> <script type='text/javascript' src='//platform-api.sharethis.com/js/sharethis.js#product=ga'></script> <script type="text/javascript" src="http://www.contentmasteryguide.com/wp-content/cache/minify/64a24.js"></script> <link rel='https://api.w.org/' href='http://www.contentmasteryguide.com/wp-json/' /><link rel='shortlink' href='http://www.contentmasteryguide.com/?p=6297' /><link rel="alternate" type="application/json+oembed" href="http://www.contentmasteryguide.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.contentmasteryguide.com%2F2017%2F05%2Fmanage-blogging-tasks.html" /><link rel="alternate" type="text/xml+oembed" href="http://www.contentmasteryguide.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.contentmasteryguide.com%2F2017%2F05%2Fmanage-blogging-tasks.html&#038;format=xml" /><style type="text/css">.enews
.screenread{height:1px;left:-1000em;overflow:hidden;position:absolute;top:-1000em;width:1px}</style><script type="text/javascript">window._wp_rp_static_base_url='https://rp.zemanta.com/static/';window._wp_rp_wp_ajax_url="https://www.contentmasteryguide.com/wp-admin/admin-ajax.php";window._wp_rp_plugin_version='3.6.1';window._wp_rp_post_id='6297';window._wp_rp_num_rel_posts='5';window._wp_rp_thumbnails=true;window._wp_rp_post_title='How+to+Manage+Your+Blogging+Tasks';window._wp_rp_post_tags=['blogging+consistently','blogging+basics','googl','sync','central','burner','calendar','free','microsoft','2014','alt','blog','tool','life','app','caption','manag'];</script> <link rel="icon" href="http://www.contentmasteryguide.com/wp-content/plugins/genesis-favicon-uploader/favicons/favicon.ico" /><style type="text/css">.site-title
a{background:url(http://www.contentmasteryguide.com/images/2017/03/hCHG-colour.png) no-repeat !important}</style><style type="text/css" media="screen">.simple-social-icons ul li a, .simple-social-icons ul li a:hover, .simple-social-icons ul li a:focus{background-color:#d66c59 !important;border-radius:4px;color:#fff !important;border:0px
#fff solid !important;font-size:20px;padding:10px}.simple-social-icons ul li a:hover, .simple-social-icons ul li a:focus{background-color:#fff !important;border-color:#fff !important;color:#d66c59 !important}.simple-social-icons ul li a:focus{outline:1px
dotted #fff !important}</style><style type="text/css">.broken_link,a.broken_link{text-decoration:line-through}</style><style type="text/css" id="wp-custom-css">.get-in-touch
a{font-size:13px;font-weight:300;padding:15px
40px;color:#fff;border-color:#d66c59;border:1px
solid #d66c59;background-color:#d66c59;border-radius:3px;-moz-border-radius:3px;-ms-border-radius:3px;-webkit-border-radius:3px}.get-in-touch a:hover{background-color:#fff}</style></head><body class="post-template-default single single-post postid-6297 single-format-standard custom-header header-image header-full-width content-sidebar" itemscope itemtype="https://schema.org/WebPage"><div class="site-container"><ul class="genesis-skip-link"><li><a href="#genesis-nav-primary" class="screen-reader-shortcut"> Skip to primary navigation</a></li><li><a href="#genesis-content" class="screen-reader-shortcut"> Skip to content</a></li><li><a href="#genesis-sidebar-primary" class="screen-reader-shortcut"> Skip to primary sidebar</a></li><li><a href="#genesis-footer-widgets" class="screen-reader-shortcut"> Skip to footer</a></li></ul><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="http://www.contentmasteryguide.com/">Content Mastery Guide</a></p><p class="site-description" itemprop="description">Blogging for Wellness Professionals</p></div><nav class="nav-primary" itemscope itemtype="https://schema.org/SiteNavigationElement" id="genesis-nav-primary" aria-label="Main navigation"><div class="wrap"><ul id="menu-main-menu" class="menu genesis-nav-menu menu-primary js-superfish"><li id="menu-item-4935" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4935"><a href="http://contentmasteryguide.com" itemprop="url"><span itemprop="name">Home</span></a></li><li id="menu-item-4877" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4877"><a href="#" itemprop="url"><span itemprop="name">Training</span></a><ul class="sub-menu"><li id="menu-item-4947" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4947"><a target="_blank" href="http://www.contentmasteryguide.com/webinar" itemprop="url"><span itemprop="name">Webinar</span></a></li><li id="menu-item-4878" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4878"><a target="_blank" href="http://www.contentmasteryguide.com/plan" itemprop="url"><span itemprop="name">Workbook</span></a></li></ul></li><li id="menu-item-26" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-26"><a href="http://www.contentmasteryguide.com/blog" itemprop="url"><span itemprop="name">Blog</span></a></li><li id="menu-item-4080" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4080"><a href="http://www.contentmasteryguide.com/linda-dessau" itemprop="url"><span itemprop="name">About</span></a></li><li id="menu-item-141" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-141"><a href="http://www.contentmasteryguide.com/testimonials" itemprop="url"><span itemprop="name">Testimonials</span></a></li><li id="menu-item-24" class="gform_button menu-item menu-item-type-post_type menu-item-object-page current-menu-item page_item page-item-22 current_page_item menu-item-24 get-in-touch menu-item-24"><a href="http://www.contentmasteryguide.com/contact" itemprop="url"><span itemprop="name">Get in Touch</span></a></li></ul></div></nav></div></header><div class="site-inner"><div class="content-sidebar-wrap"><main class="content" id="genesis-content"><article class="post-6297 post type-post status-publish format-standard category-blogging-basics category-blogging-consistently entry" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">How to Manage Your Blogging Tasks</h1><p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2017-05-17T13:05:30+00:00">May 17, 2017</time> By <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="http://www.contentmasteryguide.com/author/melanie" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Linda Dessau</span></a></span> <span class="entry-comments-link"><a href="http://www.contentmasteryguide.com/2017/05/manage-blogging-tasks.html#respond">Leave a Comment</a></span></p></header><div class="entry-content" itemprop="text"><figure id="attachment_6306" style="width: 560px" class="wp-caption aligncenter"><img class="size-full wp-image-6306" src="http://www.contentmasteryguide.com/images/2017/05/blogging-tasks-text.png" alt="" width="560" height="315" srcset="http://www.contentmasteryguide.com/images/2017/05/blogging-tasks-text.png 560w, http://www.contentmasteryguide.com/images/2017/05/blogging-tasks-text-300x169.png 300w" sizes="(max-width: 560px) 100vw, 560px" /><figcaption class="wp-caption-text">© pixome &#8211; Fotolia.com</figcaption></figure><p><span style="font-weight: 400;">There is a productivity principle that what gets scheduled gets done. This concept has definitely been central in my both my personal and work life, and is even more important when the two connect. Meal times during work days, for example, are a non-negotiable break from the computer.</span></p><p><span style="font-weight: 400;">Aside from Google Calendar, my other essential scheduling tool is </span><a href="https://www.wunderlist.com/"target="_blank" ><span style="font-weight: 400;">Wunderlist</span></a><span style="font-weight: 400;">, a beautifully-designed task management application that seamlessly syncs across multiple devices. It’s completely free to use, or you can upgrade if you want additional features.</span></p><p><i><span style="font-weight: 400;">NOTE: Since I wrote this original post in 2014 for SteamFeed (now closed), Wunderlist was acquired by Microsoft, who are turning it into a new app called To-Do. The jury is still out on whether my favourite features will survive the transition. I have </span></i><a href="https://en.todoist.com/"target="_blank" ><i><span style="font-weight: 400;">Todoist</span></i></a><i><span style="font-weight: 400;"> on the back burner, which I’ve heard is very similar to Wunderlist. It’s also comforting that I can easily </span></i><a href="https://en.todoist.com/import/wunderlist"target="_blank" ><i><span style="font-weight: 400;">import my data</span></i></a><i><span style="font-weight: 400;"> when/if the time comes.</span></i></p><p><span style="font-weight: 400;">Everything I discuss in today’s post is possible with the free version of Wunderlist, and the general ideas should also apply to whatever task management system you may already be using. We’ll cover:</span></p><ul><li style="font-weight: 400;"><span style="font-weight: 400;">Why scheduling is important for business blogging</span></li><li style="font-weight: 400;"><span style="font-weight: 400;">The benefits of Wunderlist as a blog scheduling tool</span></li><li style="font-weight: 400;"><span style="font-weight: 400;">How I use Wunderlist in my business blogging workflow</span></li><li style="font-weight: 400;"><span style="font-weight: 400;">Three steps for scheduling your business blogging tasks</span></li></ul><h2>Why scheduling is important for business blogging</h2><p><span style="font-weight: 400;">Though anyone can publish their thoughts online in an instant, effective blogging is not that simple. Before you even start writing a blog post, you need a marketing strategy, </span><a href="http://www.contentmasteryguide.com/plan"><span style="font-weight: 400;">blogging plan</span></a><span style="font-weight: 400;">, time for brainstorming, a place to </span><a href="http://www.contentmasteryguide.com/2017/04/blogging-tools-wellness-professionals.html"><span style="font-weight: 400;">capture random blog post ideas</span></a><span style="font-weight: 400;">, and an </span><a href="http://www.contentmasteryguide.com/2013/12/problem-with-planning-blog-posts.html"><span style="font-weight: 400;">outline</span></a><span style="font-weight: 400;"> you can build from later.</span></p><p><span style="font-weight: 400;">After drafting, shaping, editing and decorating, your post is ready to publish. Then there is the </span><a href="http://www.contentmasteryguide.com/2014/05/streamline-blog-publishing-promotion.html"><span style="font-weight: 400;">social media promotion</span></a><span style="font-weight: 400;">!</span></p><p><span style="font-weight: 400;">You may have a set day you like to publish on your own site, or you have a specific submission date for your clinic site or a guest post. Either way, you need to make sure all those steps are completed in enough time to meet your goal.</span></p><p><span style="font-weight: 400;">The last thing you want is to be rushing through the blogging process so you’re tempted to skip an important step like proofreading, </span><a href="http://www.contentmasteryguide.com/2014/08/top-10-reasons-use-internal-external-links-business-blog.html"><span style="font-weight: 400;">adding links</span></a><span style="font-weight: 400;">, or </span><a href="http://sproutsocial.com/insights/free-image-creation-tools/"target="_blank" ><span style="font-weight: 400;">creating a compelling image</span></a><span style="font-weight: 400;">. Scheduling your blogging time makes sure nothing gets missed.</span></p><h2>The benefits of Wunderlist as a scheduling tool</h2><p><span style="font-weight: 400;">You already know that I think Wunderlist is beautiful, and that’s important to me. If I don’t enjoy the experience of using an app, I won’t use it consistently. If I do enjoy it, that tool quickly becomes entrenched in my day-to-day routines.</span></p><p><span style="font-weight: 400;">Case in point: I started out using Wunderlist for business tasks, but now I also have a “Health and Household” list for assorted personal tasks, shopping lists for the stores I frequent, and even packing lists for trips! </span></p><p><span style="font-weight: 400;">Because it syncs so efficiently across all my devices, Wunderlist makes an excellent idea catcher for Content Mastery Guide and the other sites where I blog. Wherever I am, I can add a new title or additional ideas to something I’ve already planned.</span></p><p><span style="font-weight: 400;">I also appreciate how in Wunderlist I can sort and display my lists in different ways. For blogging, I display tasks in order of the due date. That way I can quickly get a snapshot of what I need to be working on next for each blog or client.</span></p><p><span style="font-weight: 400;">Wunderlist also has </span><a href="https://support.wunderlist.com/customer/portal/articles/1639507-smart-lists"target="_blank" ><span style="font-weight: 400;">smart lists</span></a><span style="font-weight: 400;"> like Today and Week, which display all tasks with due dates on those particular days. These help me stay realistic about what I can and will get done.</span></p><p><span style="font-weight: 400;">I use the Today list every morning day to plan my time for the day, and on the weekends I use the Week list to plot out my tasks and adjust any due dates based on my available time each day.</span></p><h2>How I use Wunderlist in my blogging workflow</h2><p><span style="font-weight: 400;">In addition to laying out the specific ways I use Wunderlist, I’ve included broader steps you can use in any scheduling system.</span></p><p><strong>Step 1: Batch your blogging tasks into scheduled blocks that make sense for you, and name those blocks.</strong></p><p><span style="font-weight: 400;">These are the blocks my team and I use for the clients who </span><a href="https://www.slideshare.net/lindadessau/12-most-tedious-blogging-tasks-you-can-outsource-final-mar-28-2014"target="_blank" ><span style="font-weight: 400;">outsource their blogging</span></a><span style="font-weight: 400;"> to us: </span></p><ol><li><span style="font-weight: 400;">Initial draft (includes research, writing, editing, choosing photos, and social media promotion text) – complete once delivered to client</span></li><li><span style="font-weight: 400;">Revisions (includes editing and proofreading) – complete once delivered to assistant</span></li><li><span style="font-weight: 400;">Production (includes publishing to site with photo, SEO optimization, and scheduling social media updates) – completed by assistant</span></li></ol><p><span style="font-weight: 400;">In Wunderlist, I have a separate list for every blog or client. In the appropriate list, I create a list item with the name of the blog post, and then add the name of the block, e.g., </span><i><span style="font-weight: 400;">How to Manage Your Blogging Tasks – initial draft</span></i><span style="font-weight: 400;">.</span></p><p><strong>Step 2: Estimate the time you will need for each of those blocks.</strong></p><p><span style="font-weight: 400;">This may be difficult at first. Overestimate your time at the beginning, until you get a clearer sense of your own blogging workflow.</span></p><p><span style="font-weight: 400;">I often use </span><a href="http://pomodorotechnique.com/"target="_blank" ><span style="font-weight: 400;">the Pomodoro Technique</span></a><span style="font-weight: 400;"> of working in concentrated 25-minute blocks, so sometimes I’ll add a </span><a href="https://support.wunderlist.com/customer/portal/articles/1641444-how-do-i-use-tags-"target="_blank" ><span style="font-weight: 400;">hashtag</span></a><span style="font-weight: 400;"> to my Wunderlist item such as #2POM. That represents one hour, with a five-minute break in the middle.</span></p><p><span style="font-weight: 400;">Sometimes I’ll also note whether this is ideally a morning task versus an afternoon task (#AM or #PM), though I can usually determine that in a split second when reviewing my lists and planning my work day.</span></p><p><strong>Step 3: Work backwards to schedule those blocks in enough time to meet your submission date.</strong></p><p><span style="font-weight: 400;">If you know you want to publish or submit on a Tuesday, and you’ve determined you’ll need three blocks of one hour each, you might start the whole process on the preceding Wednesday or Thursday.</span></p><p><span style="font-weight: 400;">Your due dates for each blogging block will depend on what else is going on in your week, and when you typically like to do your blogging.</span></p><p><span style="font-weight: 400;">If you’re lucky enough to have </span><a href="http://www.contentmasteryguide.com/contact"><span style="font-weight: 400;">help with your blogging</span></a><span style="font-weight: 400;">, you need to work those people into your schedule as well. If your editor or assistant typically needs a turnaround time of two business days, that means your final day to submit to that person must be two days ahead of your actual due date.</span></p><p><span style="font-weight: 400;">In Wunderlist, once I’ve completed one phase of the blogging process, I revise the list item with the next block name and estimated time, and forward the task’s due date to the next date. For example, </span><i><span style="font-weight: 400;">How to Manage Your Blogging Tasks – initial draft #2POM</span></i><span style="font-weight: 400;">, becomes </span><i><span style="font-weight: 400;">How to Manage Your Blogging Tasks – revisions #1POM</span></i><span style="font-weight: 400;">.</span></p><p><span style="font-weight: 400;">Wunderlist does offer the option of creating sub-tasks, so why do I type these details manually into the task title? For a couple of reasons:</span></p><ol><li><span style="font-weight: 400;">Sometimes I like to print out all tasks due on a particular day (the “Today” smart list). Sub-tasks take up more space on the page, often requiring a second page.</span></li><li><span style="font-weight: 400;">If the block name is part of the task name, I can see it at a glance when viewing a list or smart list. To see sub-tasks I’d have to click through to open up a particular task.</span></li></ol><p><span style="font-weight: 400;">Whether you use Wunderlist or another task management system, if you want to keep blogging consistently and see results from your efforts, you must schedule time for your blogging tasks.</span></p><p><i><span style="font-weight: 400;">Note: An earlier version of this post appeared on the SteamFeed blog, which is now closed.</span></i></p><div class="wp_rp_wrap  wp_rp_vertical_m" id="wp_rp_first"><div class="wp_rp_content"><h3 class="related_post_title">Related Posts</h3><ul class="related_post wp_rp"><li data-position="0" data-poid="in-4487" data-post-type="none" ><a href="http://www.contentmasteryguide.com/2016/06/keep-blogging-front-burner.html" class="wp_rp_thumbnail"><img src="http://www.contentmasteryguide.com/images/2016/06/burner-thumb-150x150.jpg" alt="12 Most Tenacious Ways to Keep Blogging on the Front Burner" width="150" height="150" /></a><a href="http://www.contentmasteryguide.com/2016/06/keep-blogging-front-burner.html" class="wp_rp_title">12 Most Tenacious Ways to Keep Blogging on the Front Burner</a></li><li data-position="1" data-poid="in-6185" data-post-type="none" ><a href="http://www.contentmasteryguide.com/2017/04/blogging-tools-wellness-professionals.html" class="wp_rp_thumbnail"><img src="http://www.contentmasteryguide.com/images/2017/04/typewriter-creative-swirls-TEXT-Depositphotos_22558903_l-2015-150x150.png" alt="Two Blogging Power Tools for Wellness Professionals" width="150" height="150" /></a><a href="http://www.contentmasteryguide.com/2017/04/blogging-tools-wellness-professionals.html" class="wp_rp_title">Two Blogging Power Tools for Wellness Professionals</a></li><li data-position="2" data-poid="in-3358" data-post-type="none" ><a href="http://www.contentmasteryguide.com/2014/12/schedule-business-blogging.html" class="wp_rp_thumbnail"><img src="http://www.contentmasteryguide.com/images/2014/12/businesss-blogging-schedule-THUMB-150x150.jpg" alt="How to Schedule Your Business Blogging Time" width="150" height="150" /></a><a href="http://www.contentmasteryguide.com/2014/12/schedule-business-blogging.html" class="wp_rp_title">How to Schedule Your Business Blogging Time</a></li><li data-position="3" data-poid="in-3123" data-post-type="none" ><a href="http://www.contentmasteryguide.com/2014/07/business-blogging-using.html" class="wp_rp_thumbnail"><img width="100" height="150" src="http://www.contentmasteryguide.com/images/2014/07/business-blogging-power-tools-THUMB.jpg" class="attachment-150x150 size-150x150 wp-post-image" alt="" /></a><a href="http://www.contentmasteryguide.com/2014/07/business-blogging-using.html" class="wp_rp_title">Two Business Blogging Power Tools You Need to Be Using</a></li><li data-position="4" data-poid="in-745" data-post-type="none" ><a href="http://www.contentmasteryguide.com/2012/09/the-secret-to-blogging-consistently.html" class="wp_rp_thumbnail"><img src="http://www.contentmasteryguide.com/wp-content/plugins/related-posts/static/thumbs/30.jpg" alt="Ten Secrets to Blogging Consistently" width="150" height="150" /></a><a href="http://www.contentmasteryguide.com/2012/09/the-secret-to-blogging-consistently.html" class="wp_rp_title">Ten Secrets to Blogging Consistently</a></li></ul></div></div><div class="nc_socialPanel swp_flatFresh swp_d_fullColor swp_i_fullColor swp_o_fullColor scale-100 scale-fullWidth" data-position="below" data-float="floatBottom" data-count="4" data-floatColor="#ffffff" data-emphasize="0"><div class="nc_tweetContainer swp_fb" data-id="3" data-network="facebook"><a rel="nofollow" target="_blank" href="https://www.facebook.com/share.php?u=http%3A%2F%2Fwww.contentmasteryguide.com%2F2017%2F05%2Fmanage-blogging-tasks.html" data-link="http://www.facebook.com/share.php?u=http%3A%2F%2Fwww.contentmasteryguide.com%2F2017%2F05%2Fmanage-blogging-tasks.html" class="nc_tweet"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw sw-facebook"></i><span class="swp_share"> Share</span></span></span></span></a></div><div class="nc_tweetContainer twitter" data-id="2" data-network="twitter"><a rel="nofollow" target="_blank" href="https://twitter.com/share?original_referer=/&text=How+to+Manage+Your+Blogging+Tasks&url=http://www.contentmasteryguide.com/2017/05/manage-blogging-tasks.html" data-link="https://twitter.com/share?original_referer=/&text=How+to+Manage+Your+Blogging+Tasks&url=http://www.contentmasteryguide.com/2017/05/manage-blogging-tasks.html" class="nc_tweet"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw sw-twitter"></i><span class="swp_share"> Tweet</span></span></span></span></a></div><div class="nc_tweetContainer googlePlus" data-id="1" data-network="google_plus"><a rel="nofollow" target="_blank" href="https://plus.google.com/share?url=http%3A%2F%2Fwww.contentmasteryguide.com%2F2017%2F05%2Fmanage-blogging-tasks.html" data-link="https://plus.google.com/share?url=http%3A%2F%2Fwww.contentmasteryguide.com%2F2017%2F05%2Fmanage-blogging-tasks.html" class="nc_tweet"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw sw-google-plus"></i><span class="swp_share"> +1</span></span></span></span></a></div><div class="nc_tweetContainer linkedIn" data-id="4" data-network="linked_in"><a rel="nofollow" target="_blank" href="https://www.linkedin.com/cws/share?url=http%3A%2F%2Fwww.contentmasteryguide.com%2F2017%2F05%2Fmanage-blogging-tasks.html" data-link="https://www.linkedin.com/cws/share?url=http%3A%2F%2Fwww.contentmasteryguide.com%2F2017%2F05%2Fmanage-blogging-tasks.html" class="nc_tweet"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw sw-linkedin"></i><span class="swp_share"> Share</span></span></span></span></a></div></div><div class="swp-content-locator"></div></div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="http://www.contentmasteryguide.com/blog/blogging-basics" rel="category tag">Blogging Basics</a>, <a href="http://www.contentmasteryguide.com/blog/blogging-consistently" rel="category tag">Blogging Consistently</a></span></p></footer></article><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/05/manage-blogging-tasks.html#respond" style="display:none;">Cancel reply</a></small></h3><form action="http://www.contentmasteryguide.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='6297' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="4c2a710028" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="135"/></p></form></div> </main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar" id="genesis-sidebar-primary"><section id="user-profile-2" class="widget user-profile"><div class="widget-wrap"><h4 class="widget-title widgettitle">About Linda</h4><p><span class="alignleft"><img alt='' src='http://1.gravatar.com/avatar/797179aceab9977c950fe6b4475fff77?s=125&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/797179aceab9977c950fe6b4475fff77?s=250&amp;d=mm&amp;r=g 2x' class='avatar avatar-125 photo' height='125' width='125' /></span>Linda Dessau is a wellness blogging expert and online writing consultant and the author of <em>Write Your Way to More Clients Online</em>. She helps wellness practitioners attract new clients through blogging and content marketing. <a class="pagelink" href="http://www.contentmasteryguide.com/linda-dessau">Read More…</a></p></div></section> <section id="recent-posts-3" class="widget widget_recent_entries"><div class="widget-wrap"><h4 class="widget-title widgettitle">Recent Posts</h4><ul><li> <a href="http://www.contentmasteryguide.com/2017/05/manage-blogging-tasks.html">How to Manage Your Blogging Tasks</a></li><li> <a href="http://www.contentmasteryguide.com/2017/05/blog-editing-essentials-build-credibility-loyalty.html">Top 5 Blog Editing Essentials That Build Credibility and Loyalty</a></li><li> <a href="http://www.contentmasteryguide.com/2017/04/generate-new-blog-post-ideas.html">Three Ways to Generate New Blog Post Ideas</a></li><li> <a href="http://www.contentmasteryguide.com/2017/04/blogging-tools-wellness-professionals.html">Two Blogging Power Tools for Wellness Professionals</a></li><li> <a href="http://www.contentmasteryguide.com/2017/03/blog-introduction-conclusion.html">Blog Readers Remember How You Made Them Feel</a></li></ul></div></section> <section id="search-3" class="widget widget_search"><div class="widget-wrap"><form class="search-form" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" method="get" action="http://www.contentmasteryguide.com/" role="search"><meta itemprop="target" content="http://www.contentmasteryguide.com/?s={s}"/><label class="search-form-label screen-reader-text" for="searchform-591d26088d4439.93285626">Search this website</label><input itemprop="query-input" type="search" name="s" id="searchform-591d26088d4439.93285626" placeholder="Search this website &#x2026;" /><input type="submit" value="Search" /></form></div></section> <section id="text-6" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Blog Topics</h4><div class="textwidget"><ul><li><a href="/how-to-use-blog">How to Use This Blog</a></li><li><a href="/blog/local-clients">Attracting Local Clients</a></li><li><a href="/blog/benefits-of-blogging">Benefits of Blogging</a></li><li><a href="/blog/blog-topic-ideas">Blog Topic Ideas</a></li><li><a href="/blog/blog-planning">Blog Planning</a></li><li><a href="/blog/blogging-basics">Blogging Basics</a></li><li><a href="/blog/blogging-consistently">Blogging Consistently</a></li><li><a href="/blog/cmg-guest-posts">CMG Guest Posts</a></li><li><a href="/blog/curation">Content Curation</a></li><li><a href="/blog/editing-tips">Editing Tips</a></li><li><a href="/blog/sharing-your-content">Social Media</a></li><li><a href="/blog/writing-tips">Writing Tips</a></li></ul></div></div></section> </aside></div></div><div class="footer-widgets" id="genesis-footer-widgets"><div class="wrap"><div class="widget-area footer-widgets-1 footer-widget-area"><section id="simple-social-icons-2" class="widget simple-social-icons"><div class="widget-wrap"><h4 class="widget-title widgettitle">Let&#8217;s Connect</h4><ul class="aligncenter"><li class="ssi-facebook"><a href="http://www.facebook.com/contentmasteryguide" ><svg role="img" class="social-facebook" aria-labelledby="social-facebook"><title id="social-facebook">Facebook</title><use xlink:href="http://www.contentmasteryguide.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-facebook"></use></svg></a></li><li class="ssi-gplus"><a href="http://google.com/+LindaDessau" ><svg role="img" class="social-gplus" aria-labelledby="social-gplus"><title id="social-gplus">Google+</title><use xlink:href="http://www.contentmasteryguide.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-gplus"></use></svg></a></li><li class="ssi-linkedin"><a href="http://www.linkedin.com/company/content-mastery-guide" ><svg role="img" class="social-linkedin" aria-labelledby="social-linkedin"><title id="social-linkedin">Linkedin</title><use xlink:href="http://www.contentmasteryguide.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-linkedin"></use></svg></a></li><li class="ssi-rss"><a href="http://contentmasteryguide.com/feed" ><svg role="img" class="social-rss" aria-labelledby="social-rss"><title id="social-rss">RSS</title><use xlink:href="http://www.contentmasteryguide.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-rss"></use></svg></a></li><li class="ssi-twitter"><a href="http://twitter.com/lindadessau" ><svg role="img" class="social-twitter" aria-labelledby="social-twitter"><title id="social-twitter">Twitter</title><use xlink:href="http://www.contentmasteryguide.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-twitter"></use></svg></a></li></ul></div></section> <section id="black-studio-tinymce-6" class="widget widget_black_studio_tinymce"><div class="widget-wrap"><h4 class="widget-title widgettitle">Media Inquiries</h4><div class="textwidget"><p>Sample interviews, suggested interview questions and Content Mastery Guide facts. <a href="/media">All media inquiries can be made here</a>.</p></div></div></section></div><div class="widget-area footer-widgets-2 footer-widget-area"><section id="enews-ext-2" class="widget enews-widget"><div class="widget-wrap"><div class="enews"><h4 class="widget-title widgettitle">Blogging Tips by Email</h4><form id="subscribeenews-ext-2" action="http://contentmasteryguide.us4.list-manage.com/subscribe/post?u=9527e1dafe1c0e624512b56bf&amp;id=6a6367bc65" method="post"  target="_blank" onsubmit="if ( subbox1.value == 'First Name') { subbox1.value = ''; } if ( subbox2.value == 'Last Name') { subbox2.value = ''; }" name="enews-ext-2"> <label for="subbox1" class="screenread">First Name</label><input type="text" id="subbox1" class="enews-subbox" value="" placeholder="First Name" name="FNAME" />				<label for="subbox2" class="screenread">Last Name</label><input type="text" id="subbox2" class="enews-subbox" value="" placeholder="Last Name" name="LNAME" />				<label for="subbox" class="screenread">E-Mail Address</label><input type="email" value="" id="subbox" placeholder="E-Mail Address" name="EMAIL" required="required" /> <input type="submit" value="HELP ME BLOG BETTER!" id="subbutton" /></form></div></div></section></div><div class="widget-area footer-widgets-3 footer-widget-area"><section id="black-studio-tinymce-7" class="widget widget_black_studio_tinymce"><div class="widget-wrap"><h4 class="widget-title widgettitle">Contact</h4><div class="textwidget"><p>Phone: 705-737-3491 (Eastern)</p><p>Postal Address: Content Mastery Guide<br /> c/o Suite Success at ESS Direct<br /> 411 Huronia Road, Unit #5<br /> Barrie, ON L4N 9B3</p><p style="text-align: left;"><a class="button large" href="/contact">Get In Touch</a></p></div></div></section></div></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><nav class="nav-footer"></nav><p>Copyright &#x000A9;&nbsp;2017 All Rights Reserved · <a href="http://www.contentmasteryguide.com/privacy-policy" title="Privacy Policy">Privacy Policy</a> · Website created by <a href="http://www.studiodpi.com" title="STUDIO dpi" target="_blank">STUDIO dpi</a></p></div></footer></div><script type='text/javascript'>jQuery(document).ready(function(){jQuery(".testimonials-list").lightSlider({auto:true,controls:true,item:1,mode:'slide',pauseOnHover:true,loop:true,pause:6000,responsive:[{breakpoint:1023,settings:{item:2}},{breakpoint:860,settings:{item:1}}]});});</script><noscript><img height='1' width='1' style='display: none;' src='https://www.facebook.com/tr?id=1281666278538292&ev=PageView&noscript=1&cd[domain]=www.contentmasteryguide.com' alt='facebook_pixel'></noscript><noscript><img height='1' width='1' style='display: none;' src='https://www.facebook.com/tr?id=1281666278538292&ev=GeneralEvent&noscript=1&cd[post_type]=post&cd[content_name]=How+to+Manage+Your+Blogging+Tasks&cd[post_id]=6297&cd[content_category]=Blogging+Basics%2C+Blogging+Consistently&cd[domain]=www.contentmasteryguide.com' alt='facebook_pixel'></noscript> <script type="text/javascript">var pys_edd_ajax_events=[];</script> <script>jQuery(document).ready(function(){jQuery.post('http://www.contentmasteryguide.com?ga_action=googleanalytics_get_script',{action:'googleanalytics_get_script'},function(response){var F=new Function(response);return(F());});});</script> <script type="text/javascript" src="http://www.contentmasteryguide.com/wp-content/cache/minify/50842.js"></script> <script type="text/javascript">/*<![CDATA[*/var swpClickTracking=false;var swp_nonce="fa53d59f61";var within_timelimit;swp_admin_ajax='https://www.contentmasteryguide.com/wp-admin/admin-ajax.php';var swp_buttons_exist=!!document.getElementsByClassName('nc_socialPanel');if(swp_buttons_exist){jQuery(document).ready(function(){var swp_cache_data={'action':'swp_cache_trigger','post_id':6297,'timestamp':1495082504};console.log("Server Timestamp is "+swp_cache_data.timestamp);var browser_date=Date.now();if(!browser_date)
browser_date=new Date().getTime();browser_date=Math.floor(browser_date/1000);console.log("Browser Timestamp is "+browser_date);var elapsed_time=(swp_cache_data.timestamp-browser_date);if(elapsed_time>60){console.log("Elapsed time since server timestamp is greater than 60 seconds -- "+elapsed_time+"seconds");within_timelimit=false;}else{console.log("Elapsed time since server timestamp is less than 60 seconds -- "+elapsed_time+"seconds");within_timelimit=true;}
if(within_timelimit===true){jQuery.post(swp_admin_ajax,swp_cache_data,function(response){console.log(response);});socialWarfarePlugin.fetchShares();}});swp_post_id='6297';swp_post_url='http://www.contentmasteryguide.com/2017/05/manage-blogging-tasks.html';swp_post_recovery_url='';}/*]]>*/</script></body></html>